Terraform for linux not working with vsphere provider

I am trying out terraform with vsphere provider to understand how it works with vsphere automation. I am running into issues with the linux version of terraform. I am using Terraform 0.15.3 with vsphere provider 1.26. I am seeing the following issues. Terraform init works fine. But I am running into the following issue with terraform plan and apply commands.

Error: error setting up new vSphere SOAP client: Post “https://10.29.236.150/sdk”: Gateway Timeout

│ with provider[“registry.terraform.io/hashicorp/vsphere”],
│ on main.tf line 1, in provider “vsphere”:
│ 1: provider “vsphere” {

My main.tf looks like this:

provider “vsphere” {
user = “administrator@vsphere.local”
password = var.vc_password
vsphere_server = var.server_ip
allow_unverified_ssl = true
}

data “vsphere_datacenter” “dc” {
name = “DCN-DC”
}

output “datacenter_id” {
value = data.vsphere_datacenter.dc.id
}

output “datacenter_name” {
value = data.vsphere_datacenter.dc
}

I have tried the binary on ubuntu 20.04.2 and centos 8.3. I have also tried terraform versions 0.15.1, 0.14.11 and 0.14.9 with the exact same error. The same main.tf works fine on my mac running terraform 0.15.3 and vsphere provider 1.26.

not sure what the issue is on linux

Figured this out. Authentication was not going thru due to my proxy settings. Had to exclude my internal server ip address space using an export no_proxy=“10.0.0.0/xx, 192.168.0.0/xx, *.my.com, 127.0.0.0/8”. That allowed vsphere authentication to go thru. The Gateway time out error threw me off.