TTL not working while generating mysql credentials

I have enabled database Mysql for generating dynamic vault credentials.

For a particular database role i have following TTL vaules

default_ttl           86400                                                                                                                           
max_ttl               604800 

Now I want to generate database credentials with some custom TTL
I am using below mentioned command for that

read database/creds/my_role_name ttl=60h

but when I check at lease the credentials are always generated for the default TTL vaule.
I am using vault(3 node) along with consul(3 node)
vault version : 1.0.3
consul version : 1.4.3

I don’t think that you can define the ttl using vault read. I have never seen it and the ttl parameter is not mentioned in the docs.

Is there any way by which i can generate database credentials using custom TTL ?

When you create a role, the parameter rotation_period defines the ttl for the password. Another role, another rotation_period another ttl.

I haven’t found any way in the documentation to influence this per generation of a credential.

[…] The administrator specifies the TTL of the database credentials to enforce its validity so that they are automatically revoked when they are no longer used.