Unable to bind containers to 0.0.0.0

I’m trying to make nomad containers listen on 0.0.0.0.
By default, they bind to the first private IP, but when I tried to access it it didn’t work (even though I can access SSH that’s directly on the server using the IP, I’m on the same network and there are no firewalls set up between my computer and the server).
I tried adding networks binded to 0.0.0.0/0 but it instead binds to localhost.

Tried with both podman and docker drivers.

Hi @danbulant.

When starting the Nomad client, are you passing any client configuration options? The client.network_interface configuration option may be useful to help achieve the goal you desire.

Thanks,
jrasell and the Nomad team

I’m using the ansible nomad role to automate setting up nomad (along with consul and adding jobs).

The generated config has the network_interface option set to correct value.

I just set up nomad on a VPS with just two interfaces (loopback and eth0 with direct internet access) and it worked just fine, while the desktop didn’t work. Both run Arch linux.