Unable to publish terraform-provider-solace

Hello! I’ve been trying to publish my terraform-provider-solace for a while and I keep getting various errors back and no success. I’m using goreleaser as on the documentation page and have verified that my signatures file contains the correct SHA256 sums for the zip files and that the SHA256SUMS file has a valid signature from the correct GPG key.

The errors I get are (sometimes one, sometimes the other):

  • No valid platform assets found
  • Missing release asset for [“terraform-provider-solace_0.6.2_manifest.json”]

I’ve tried giving it time (days), new versions (tags), a different GPG key, resending the web hook, a different repository and a few other random things but no luck so far. I also filed a ticket with Hashicorp support a few weeks ago, but got no response.

Any hints on what might be going wrong here?

Hi there!

I noticed that your manifest.json file has trailing commas. Strictly-speaking, that’s invalid JSON, and I’ve seen that cause the same not-very-helpful error message in the past. Could you try removing those commas and publishing again?


You da man! That worked perfectly, the provider published! Thanks for the advice.