Using tcg, qemu virtual machine opens in qemu mode. And the boot command doesn't respond to it

This is what it looks like:

Now those commands are typed in manually while the hcl script is running.

This is not what I’m used to with KVM.
I need to use TCG, because the distro type I want to use has become ARM-only.

I’m at a loss on what to do.

Hey there,

Qemu has several ways to interact with it, you’re looking at the monitor, which is a way to interact with the emulator directly, not with the guest OS.

You can disable that through the -monitor none argument to qemu. In Packer there isn’t a specific setting for this, but you can specify it in the qemuargs settings, like so (in HCL2):

qemuargs = [
  ["-monitor", "none"],
]

Alternatively, you can select which output you’re viewing in the qemu interface, one of those will let you see the installation process.

Hopefully this’ll help!

1 Like

Not really, now it’s just an empty shell.

But I’ve also found that starting the creating the VM with TCG aarch64 virt manually throws me into the UEFI shell: