Vagrant cannot ssh after restarting MacBook (vagrant, homestead, parallels)

I have used vagrant with VirtualBox for years to run my Laravel Homestead environment. Now after changing to a new MacBook (M3 Pro, Sonoma 14.4) I needed to switch to Parallels. I have successfully configured Vagrantfile and Homestead.yaml, and everything worked from the beginning.

The problem is, whenever I restart my MacBook, I cannot “vagrant up” or “vagrant reload” anymore. It stops to the SSH part of the script. And I cannot ssh into the VM. When I do “vagrant destroy” and “vagrant up”, I works again until the next Mac restart.

I have tried setting up my own private SSH keys, as well as the defaults both setting “config.ssh.insert_key” to “false” and “true”. All these alternatives lead to the same exact result. Everything works at first but not after reboot. I have also manually started the VM but it didn’t help.

Any advice on this?

EDIT: This might have something to do with dynamic IP’s provided by Parallels. It seems the IP changes on every restart.