Laravel homestead gets stuck at SSH auth method private key

I am trying to get laravel Homestead to work but it keeps getting stuck at SSH auth method private key during boot up. I know this is a very common issue and I have tried everything to fix it yet nothing works.

I am using VirtualBox 6.1.36 and the latest version of vagrant and homestead. My machine is a Lenovo ThinkBook 15 Gen 2 AMD using windows 10.

I have enabled AMD V in the Bios and I have turned off Hyper-V and windows hypervisor platform and virtual machine platform in the windows settings.

I have checked the VirtualBox networking settings and the cable connect setting is ticked by default.

I have SSH keys installed on my machine.

The machine boots up if I control c while it hangs and do a vagrant status but if I do vagrant SSH it does nothing and returns to the command prompt.

The homestead yaml files looks like this:

ip: “” memory: 2048 cpus: 2 provider: virtualbox authorize: ~/.ssh/ keys: - ~/.ssh/id_rsa folders: - map: ~/code to: /home/vagrant/code sites: - map: homestead.test to: /home/vagrant/code/public databases: - homestead features: - mysql: true - mariadb: false - postgresql: false - ohmyzsh: false - webdriver: false services: - enabled: - “mysql”

- disabled:

- “postgresql@11-main”


- send: 33060 # MySQL/MariaDB

to: 3306

- send: 4040

to: 4040

- send: 54320 # PostgreSQL

to: 5432

- send: 8025 # Mailhog

to: 8025

- send: 9600

to: 9600

- send: 27017

to: 27017

So as you can see I have tried virtually everything that is recommended to fix this but it still won’t work.

Really need to get this working asap