Vagrant up: "SSL certificate problem: certificate has expired"

I set up a new Laravel project, installed Homestead and Vagrant.

Before running Vagrant, I followed the Laravel docs to install Homestead per project:
I ran composer require laravel/homestead --dev, php vendor/bin/homestead make and then vagrant up which printed:

Bringing machine 'project-name' up with 'virtualbox' provider...
==> project-name: Box 'laravel/homestead' could not be found. Attempting to find and install...
    project-name: Box Provider: virtualbox
    project-name: Box Version: >= 11.0.0, < 12.0.0
==> project-name: Loading metadata for box 'laravel/homestead'
    project-name: URL: https://vagrantcloud.com/laravel/homestead
==> project-name: Adding box 'laravel/homestead' (v11.4.0) for provider: virtualbox
    project-name: Downloading: https://vagrantcloud.com/laravel/boxes/homestead/versions/11.4.0/providers/virtualbox.box
An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try
again.

SSL certificate problem: certificate has expired

It had failed to download it using the command, so I’ve downloaded the remote file manually from a browser and tried to add it to the VirtualBox VMs renaming the extension to .vbox but it says Start tag expected, '<' not found.; I thought it was compressed so I’ve extracted it and retried but it returns the same error.

May I know where the file should go to run vagrant successfully or how to resolve the error?

I solved the issue running:

vagrant box add laravel/homestead --insecure

Now when I run vagrant up it runs successfully.