Vagrant does not work at all

I upgraded to vagrant version 2.2.18 and now I cannot get vagrant to work.

I deleted the ~/.vagrant directory and every other directory I could find to start completely over.

Description: Pop!_OS 21.04

vagrant --version
Traceback (most recent call last):
4: from internal:gem_prelude:2:in <internal:gem_prelude>' 3: from <internal:gem_prelude>:2:in require’
2: from /usr/lib/ruby/vendor_ruby/rubygems.rb:1348:in <top (required)>' 1: from /usr/lib/ruby/vendor_ruby/rubygems.rb:1348:in require’
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:43:in <top (required)>': uninitialized constant Gem::BasicSpecification (NameError) Traceback (most recent call last): 4: from <internal:gem_prelude>:2:in internal:gem_prelude
3: from internal:gem_prelude:2:in require' 2: from /usr/lib/ruby/vendor_ruby/rubygems.rb:1348:in <top (required)>’
1: from /usr/lib/ruby/vendor_ruby/rubygems.rb:1348:in require' /usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:43:in <top (required)>’: uninitialized constant Gem::BasicSpecification (NameError)

Have you tried purging it and then installing an older version or do you really need the newer one?

sude apt-get purge vagrant
sudo apt list -a vagrant
sudo apt install vagrant=2.x.x

Thanks for the response.

I have seen regularly the admonition that I should not use the ubuntu repositories and instead run a curl command like:

curl -O

It has always worked in the past. I was in a hurry, so installed using the apt commands, it install 2.2.18 and it is working fine. So I did not do anymore trouble shooting.

And thank you for your response.
Vagrant is no longer working for me either.