Vagrant package produces broken package

Since 2.2.9 (at least for me) Vagrant complains about base_mac when the syntax is not colon-separated (and yes there is a recent post about this already, but it does not bring the issue to the point, so I decided to do this new topic to bring the real problem to attention.

This change is pretty spicy. … Spicy, why? Because vagrant’s own package commands writes a Vagrantfile (internal to the box, preparing the VM’s load) with a base_mac without colons, digits-only, triggering this error. Try in a directory:
vagrant init centos/7 --minimal
vagrant package
vagrant add foo/bar package.box
# Syntax of above cited from the back of my head, recheck if necessary
In another directory:
vagrant init foo/bar
vagrant up
Then cry, bitterly!

My projects depend on resized (aka packaged) VMs. My customer is breathing down my neck to get a delivery. Hashicorp found a brillant timing for a defect release.

What makes the catastrophy complete. If I add the packaged box and try to fix the base_mac by adding colons: vagrant up does not complain anymore but when trying to setup the networking … pauses for ever. Nor error, no stop, just dead.

Even more spicy: when adding the box and then complely removing the base_mac everything runs like a charm.

So I will attempt this as a workaround: I will now create - painfully, because I hate powershell - a script kicking all the base_macs from the added boxes, in order to fix them to run with 2.2.9.

I cannot even describe the damage that this “update” caused to me. Next I do is implement a test-process for this tool, because the testing quality at hashicorp is poor … I would use a completely different word, but I do not want to offend the casual reader’s taste.

What did cost me even more time: I would have reverted to 2.2.7 and really managed to get this running, but then the ordeal of getting the vmware-desktop provider start: 2.1.0 ist apparantly not compatible to 2.2.7 and 2.0.3 is not installable anymore I trying to nail the --plugin-version but then the plugin is “not found”.

I lack enough political correct swearwords of what I think about Ruby, with its gem compatibility hell poisoning my life for long years, now. But combined with a defect in a production version causing the inability to rollback to a previous version this is really make my life a hell.

I am desperate! Please! Someone give me a hint on either:

  • how to install the vagrant-vmware-desktop plugin in a previous version, allowing me to revert to 2.2.7 with 2.0.3 as plugin. Which worked.
  • how to make “vagrant package” not create a base_mac
  • any other means of getting out of this mess

Thanks in advance
Best Regards,
Koffeiniker (for this interested, it’s German for “caffeine-addicted”)

PS: I use vmware-desktop provider and VMware Workstation 15.most-actual. All worked with Vagrant 2.2.7 and vmware-desktop 2.0.3 (I believe). Since 2.2.9 I am dead in the water.

Hi there,

I provided a response yesterday to your support ticket, and just to confirm, fixes for the issues you have described will be released today. Again, my apologies for the inconvenience it has caused and it will be resolved shortly.