Vagrant port already in use

I am getting this error while running vagrant up even though there is only one container running on my machine

Vagrant cannot forward the specified ports on this VM, since they
would collide with some other application that is already listening
on these ports. The forwarded port to 9991 is already in use
on the host machine.

To fix this, modify your current project's Vagrantfile to use another
port. Example, where '1234' would be replaced by a unique host port: :forwarded_port, guest: 9991, host: 1234

So, I destroyed the container, then ran vagrant global-status --prune.
Output of vagrant global-status --prune:

vagrant global-status --prune
id       name   provider state  directory                           
There are no active Vagrant environments on this computer! Or,
you haven't destroyed and recreated Vagrant environments that were
started with an older version of Vagrant.

Then I ran vagrant up again, and still get the above error.
What should I do?
Output of vagrant global-status --prune after running vagrant up:

id       name    provider state     directory                           
3a93370  default docker preparing /home/ganpa/source/zulip


Output of vagrant version:

Installed Version: 2.2.14
Latest Version: 2.2.14

What is the output of

netstat -pan | grep 9991 # maybe prefixed with sudo

on your host?

Output of netstat-nat -pan:

Proto NATed Address                  Destination Address            State

I’m on Manjaro Linux.