Value must be a valid UUID AzureRM

Hi,

I have an issue that appeared today on which I am working for a year. So yesterday I did ubuntu PC upgrade and get the newest version of terraform v1.2.3, but now when I apply the code from my stack I am getting the following error:

[2022-06-22T15:07:34.115] [ERROR] default - ╷
│ Error: Value must be a valid UUID

│ with azuread_application.verisstaging-userms-construct_verisstaging-userms-application_D9534B35,
│ on cdk.tf.json line 459, in resource.azuread_application.verisstaging-userms-construct_verisstaging-userms-application_D9534B35:
│ 459: “owners”: [
│ 460: “${data.azurerm_client_config.verisstaging-userms-construct_verisstaging-userms-client-config_71A7475F.object_id}”
│ 461: ],

And this is the code the error is coming from:

const sp = new ServicePrincipal(this, `${id}-service-principal`, {
  applicationId: registeredApp.applicationId,
});
new ApplicationPassword(this, `${id}-application-password`, {
  applicationObjectId: registeredApp.objectId,
});
new RoleAssignment(this, `${id}-role-assignment`, {
  scope: this.app.id,
  roleDefinitionName: "Contributor",
  principalId: sp.objectId,
});

Also only one time I get this warning:

“use_microsoft_graph”: [DEPRECATED] This field now defaults to true

I tried searching on how to get the Microsoft graph upgraded but no results.

Any solution regarding this error?

1 Like

Hi @Shurbeski ,
We had the same issue. The problem had to do with an unplanned upgrade to our local AZ CLI version. 2.37 appears to cause this issue. We downgraded our AZ CLI to 2.36 and that fixed it for us.

Chris

1 Like