Vault.service existing with status 203/EXEC

Hello All,

I am running open source version of vault in production mode on AWS EC2 instance. I upgraded the vault from 1.11 to 1.15.5. If I run the vault using systemctl it errors out with following “vault.service: Main process exited, code=exited, status=203/EXEC”

However, if I run the vault directly from command line. i.e. same command used under “ExecStart” in service file it works fine.

ExecStart=/usr/bin/vault server -config=/etc/vault.d/vault.hcl

I also enabled debugging on systemctl config to check if I can get more insight, however, this is the only error I get.

Unable to understand what is really going on here.
I see a lot of people also faced this error earlier.

Reaching out to the community for help.


This is just a guess as there isn’t much to go on but have you looked at the permissions/ownership of the vault binary?

ls -l /usr/bin/vault

I assume that the service file is running Vault as a user, not root. You didn’t mention if you tried running the Vault binary as that user or not? I doubt SELinux would be a culprit as that should have prevented you from executing the binary manually if it were an issue.

And finally have you checked for any clues in Vault’s log file?

Thanks for looking at this Steven.
The service file is configured to run the service as vault user.
The vault executable under /usr/bin is owned by root

The vault binary was executed as a root user. Log file only mentioned 203 error, nothing much in there.