Vault setup.exe is not running

I have downloaded Vault setup from hashicorp and trying to run on my personal laptop.
I have set path also in environment settings like below:-
D:\HashiCorp\vault_1.4.0_windows_amd64\vault.exe (Do we need to use ; also in end after variable set - Pls confirm)

And when I am trying to run setup as “Run as Adminsitrator” a black screen with cmd comes up for a second and gone.
Anyone can please suggest.

1 Like

Hi, AFAIK, HashiCorp distributes the official binaries as zip files only, there is no setup.exe of the tools.

could you confirm the download link, where you downloaded the binary/zip from?

after you unzip the vault binary, try running the command vault.exe agent -dev

If this doesn’t work, can you try starting the cmd.exe as Administrator and then trying the same command as above.

Yes I download zip folder from Hashicorp website only. Once extracted and running file as right click “run as administrator” nothing happens.
Tried as per your suggestion but getting error. See attached image.
vault error

vault.exe server -dev

See screenshot pls. I am not able to find anywhere in messages that my server is running.

You were typing sever missing an ‘r’ in the middle of the first parameter.

vault.exe server -dev

1 Like

Ohh Oops (Silly mistake from my side), Thanks alot @Wolfsrudel . I got it. Server started.

That’s not silly. It’s human. :wink:


@Wolfsrudel Any idea to come out with this Window? If I press CTRL+C vault went down.

I don’t know exactly how to run jobs in background on Windows. Maybe as service or you will have to Google it.

Seems I have to write a program on Windows as there is no such feature or better I have to build a Linux machine on my VM :slight_smile:

whoops … muscle memory from consul/nomad :frowning_face: