Waypoint deploy exits with non-descriptive error - ! error reading from server: EOF

Hi,

I’m having an issue deploying nomad jobs that have the scheduler type ‘batch’. We’re using nomad periodic jobs to run scheduled tasks and have successfully deployed this to our QA and staging environments about 2 months ago. We then tried deploying to our production environment about 1 month ago and get the error mentioned ! error reading from server: EOF. No other message is printed so it’s been hard tracking down the issue.

I’ve tried simplifying both the waypoint.hcl and the nomad config, but it still fails. Not sure if its useful to note that we can deploy directly to nomad; this only fails with waypoint up or waypoint deploy.

Let me know if I can provide more information. I didnt include either the waypoint.hcl or nomad spec since even a barebones example file doesnt work. I’m looking for a solution or a nudge in the right direction since the error printed doesn’t give me much (I’ve tried -vvv too)