Why is the helm provider skipping a rendered manifest?

I’m using the logging-operator-logging helm chart from BanzaiCloud with terraform. Terraform successfully installs the pre-requisite logging-operator helm chart to provide CRDs and the operator for the logging-operator-logging helm chart. However, when installing the logging-operator-logging helm chart, it seems to skip one of the rendered manifests.

This EventTailer manifest (seen with a helm template command using the values terraform renders in the plan, which is passed to the helm release) doesn’t seem to get applied at all.
Screen Shot 2022-04-26 at 4.32.01 PM

When I run terraform, which applies the helm chart, it installs all the expected manifests except this EventTailer manifest in the screenshot above. There are no errors and terraform apply exits cleanly when finished applying.

After applying, I use kubectl to search for the EventTailer object and its missing:

% kubectl get EventTailer -A
No resources found

If I run “helm get values” on the release that terraform successfully applies and use the rendered template for the EventTailer manifest in the output to manually create it with kubectl, it shows up as expected.
Screen Shot 2022-04-26 at 4.37.16 PM

Last thing to note, if I run helm install manually using the terraform output of the rendered values in the terraform plan, it does successfully install and the EventTailer object shows up as expected.

I can only conclude that for some reason, the helm provider is skipping the EventTailer. I don’t know how to debug this any further but I’m at a loss on what to do to resolve this issue. Any ideas or suggestions would be greatly appreciated :slight_smile:

Terraform Version: 1.1.6
Terraform Helm Provider version: 2.5.1
Helm chart that is giving me trouble when used with terraform: logging-operator-logging 3.17.4 · helm/banzaicloud-stable

1 Like

Tried updating to the latest terraform kubernetes provider and still having this issue:

terraform {
  required_version = "~> 1.1.6"

  required_providers {
    aws = {
      source  = "hashicorp/aws"
      version = "~> 3.43.0"
    }
    kubernetes = {
      source  = "hashicorp/kubernetes"
      version = "~> 2.11.0"
    }
    helm = {
      source  = "hashicorp/helm"
      version = "~> 2.5.1"
    }

  }
}