Adding Linux REPO to RedHat Satellite

We are trying to add the Hashicorp Linux REPO to our RedHat Satellite server, and having it auto sync daily (will possibly upgrade to enterprise in the future). However when adding it to the Satellite, no files can be downloaded/found. We can do this manually via “dnf reposync”, however thats a manual process which we want to try to avoid, even with CRON.

The URLs we tried are:

https://rpm.releases.hashicorp.com
https://rpm.releases.hashicorp.com/RHEL/
https://rpm.releases.hashicorp.com/RHEL/8/
https://rpm.releases.hashicorp.com/RHEL/8/x86_64/
https://rpm.releases.hashicorp.com/RHEL/8/x86_64/stable/

All tried with and without the slash at the end. We also tried using Yum Repo Discovery to no availability.

Hi @SmoothJ,

I want to first caveat that I’m not actually familiar with any modern Linux distributions that use RPMs, so I’m responding here only based on what I know from the documentation and not from any practical experience. You may well see why what I’m about to suggest is obviously wrong, but I’m suggesting only in the hope it might be a helpful clue.

When I look at the documentation about the RPM package repositories I see it state a URL format like this:

https://rpm.releases.hashicorp.com/$release/hashicorp.repo

I believe $release here is a placeholder for what you listed as RHEL in your examples, so by my interpretation of the docs the expected repository URL would be the following:

https://rpm.releases.hashicorp.com/RHEL/hashicorp.repo

Does including that extra filename on the end of the URL help? Or is there something special about this “reposync” feature that means it requires a different sort of configuration than it would to directly add the repository?

(If anyone who sees this knows dnf better than I do – that is, knows it at all :upside_down_face: – please do chime in and give a more learned answer! :grinning: )