Allow service (fabio) to auto register to consul in consul/nomad cluster (hashicorp/learn-nomad-cluster-setup)

I am using the hashicorp/learn-nomad-cluster-setup and following the aws cluster tutorial to create a nomad/consul cluster.

I have the cluster running and I can submit jobs. I have an http-echo job running and now I want to use fabio to route traffic to that service.

The problem is fabio auto-registers to consul but consul does not allow any service to auto register unless it is done via nomad.

My question is: what do I have to change configuration wise to enable fabio to autoregister?

Thank you,
-drd