Azurerm Provider plugin error

I have been using azurerm provider version 3.53.0 past few days and everything was working fine.
when i downgraded version to 3.50.0 and initialized plugins. it worked well.
Later, i have upgraded the azurerm provider version back to 3.53.0 and this time i am getting an error while running terraform plan.
Below is the error:

terraform plan

│ Error: Required plugins are not installed

│ The installed provider plugins are not consistent with the packages selected in the dependency lock file:
│ - Terraform Registry the cached package for Terraform Registry 3.53.0 (in .terraform\providers) does not match any of the checksums recorded in the dependency lock file

│ Terraform uses external plugins to integrate with a variety of different infrastructure services. To
│ download the plugins required for this configuration, run:
│ terraform init

p.s: I even tried deleting the lockfile and ran terraform init and plan. the error still pops-up.

Please help me find the cause for this error and how to resolve this ?