Error: Failed to install databricks provider

Trying to deploy databricks resource into azure using terraform when i am trying to initialize getting below error.

C:\Temp\Terraform\Test>terraform init

Initializing the backend...

Initializing provider plugins...
- Finding databrickslabs/databricks versions matching "0.3.7"...
- Reusing previous version of hashicorp/azurerm from the dependency lock file
- Using previously-installed hashicorp/azurerm v2.73.0
- Installing databrickslabs/databricks v0.3.7...
╷
│ Error: Failed to install provider
│
│ Error while installing databrickslabs/databricks v0.3.7: archive has incorrect checksum
│ zh:298e63588879abf0dd4c8b5610312ac0644c806d2bda102ee3bcfb7f7eaa13a5 (expected
│ zh:fd2b875e9949371a0fb33c98565d352806ef8b448c8f0198acdae2e541712d5f)
╵


C:\Temp\Terraform\Test>terraform -version
Terraform v1.0.5
on windows_amd64
+ provider registry.terraform.io/hashicorp/azurerm v2.73.0

Hi @Saikishore031,

Unfortunately it seems like the distribution archive for this provider got corrupted when Terraform tried to download it.

I verified that the registry entry for this provider package seems correct, like this:

$ wget https://github.com/databrickslabs/terraform-provider-databricks/releases/download/v0.3.7/terraform-provider-databricks_0.3.7_SHA256SUMS
$ cat terraform-provider-databricks_0.3.7_SHA256SUMS 
1590ab45a63d29bd59aecc4f802a09e6ea17a4e9f0b3f984cc407a786b258083  terraform-provider-databricks_0.3.7_linux_arm.zip
3413a9e5cf5315c3ceb640deefcb820f0b0f6b11686098b73dd6f6e0dd50c493  terraform-provider-databricks_0.3.7_linux_amd64.zip
4bb1305244c3fee56cbd869f47495d27ff9a068fd786de6944721cd892050b36  terraform-provider-databricks_0.3.7_windows_arm.zip
57101fdc2d494f45477c0211f01da29ef85b279260087eff978eb7096486e5d4  terraform-provider-databricks_0.3.7_linux_arm64.zip
6d30f25728a9376b6c8e71680d98a1b8a31b44d5c285e3e40813f5e1abaf4214  terraform-provider-databricks_0.3.7_darwin_amd64.zip
6f149f7bb2617f15890b0e33e0d89565495613d84580638c35d50183904bc29e  terraform-provider-databricks_0.3.7_darwin_arm64.zip
ebba6394e337850d7f7db8b755241340a2a06866c70438713234b5ad7d2e25a9  terraform-provider-databricks_0.3.7_linux_386.zip
ef2819d68ad5cebc0a8d94d90a160d5794c724eaa671c961a21cfcd22574fdf0  terraform-provider-databricks_0.3.7_windows_386.zip
fd2b875e9949371a0fb33c98565d352806ef8b448c8f0198acdae2e541712d5f  terraform-provider-databricks_0.3.7_windows_amd64.zip
$ wget https://github.com/databrickslabs/terraform-provider-databricks/releases/download/v0.3.7/terraform-provider-databricks_0.3.7_windows_amd64.zip
--2021-08-26 18:16:10--  https://github.com/databrickslabs/terraform-provider-databricks/releases/download/v0.3.7/terraform-provider-databricks_0.3.7_windows_amd64.zip
$ sha256sum *.zip
fd2b875e9949371a0fb33c98565d352806ef8b448c8f0198acdae2e541712d5f  terraform-provider-databricks_0.3.7_windows_amd64.zip

(I’m afraid I’m using a Linux system rather than a Windows system, so the commands I wrote above are what I ran on Linux, but hopefully you can find some equivalent steps to run to get the same result on your Windows system.)

The provider author’s checksums file says that the package checksum for the windows_amd64 package should be fd2b875e9949371a0fb33c98565d352806ef8b448c8f0198acdae2e541712d5f, which is the same checksum included in your error message. When I downloaded the file and calculated the checksum myself, I also got the same result.

Given this, unfortunately I have to assume that there’s something affecting your network connection to GitHub’s download server, which is somehow intercepting the download request and producing a corrupted result, which Terraform then correctly detects and returns this error. Are you using Terraform on a network that has any special firewall or proxy software that could be interfering with Terraform’s connection to download this plugin?