Can't install Waypoint due to "ghost" volume


After a fresh Nomad install, I ran two jobs for the aws-ebs-csi-driver and proceed to install Waypoint.

After running the following command:

waypoint install -platform=nomad -accept-tos -nomad-csi-volume-provider=aws-ebs0 --nomad-csi-volume-capacity-min=10737418240 -nomad-csi-volume-capacity-max=16106127360 -nomad-consul-service=true

The driver keeps telling me that theres already a volume with the name “waypoint”, and it fails:

❌ Creating persistent volume
! Error installing server into nomad: Failed creating Nomad persistent volume ID waypoint: Unexpected response code:
  500 (1 error occurred:
  	* controller create volume: CSI.ControllerCreateVolume: volume "waypoint"
  already exists but is incompatible with these parameters: rpc error: code =
  AlreadyExists desc = Could not create volume "waypoint": Parameters on this
  idempotent request are inconsistent with parameters used in previous request(s)

If I run nomad volume status or look into the UI, there’s no available CSI volumes registered or created.

What should I do?

Somehow after updating the cli to 0.9.0 solved the issue.