Consul Official Docker Container and Connect with Envoy


I am using the Official Consul Container (1.9.3) on a docker host network, running in Server mode.
There are some services that are also registered on that host.
( registration process: Service definition json are put in a shared directory mapped to the Consul Container, and the Server is reloaded)

On this same machine, how would I use Consul Connect?

I’ve installed envoy v1.16.0 via an rpm.
I ran consul connect envoy -sidecar-for basic-http-1 -grpc-addr=my_interface:8502 -admin-bind localhost:19001 -bootstrap

I then started envoy via an envoy -c /path/to/bootsrap.json

How will I run the services so the envoy sidecar can be started?

(Some clarification maybe necessary, this question might not be the best w/ detail)

On the same “host” that has the Official Consul Image running in server mode,


    "bootstrap_expect": 1,
    "datacenter": "dc1",
    "data_dir": "/consul/data",
    "domain": "consul",
    "enable_local_script_checks": true,
    "encrypt": "mykey",
    "leave_on_terminate": true,
    "log_level": "INFO",
    "rejoin_after_leave": true,
    "server": true,
    "retry_join": [
    "ui_config": {
      "enabled": true
    "ports": {
      "grpc": 8502
    "connect": {
      "enabled": true

A Service definition:

service {
name = "basic-http"
id = "basic-http-1"
port = 8090

  connect {
sidecar_service {}

  check {
id = "basic-check-01"
http = "http://localhost:8090/index.txt"
method = "GET"
interval = "10s"
timeout = "1s"