Creating multiple subnets at the same time fails

Hi, I came up with an issue that when I try to spin up an environment which has 5 subnets to be created during first “terragrunt run-all apply” I got an error:

│ Error: creating Subnet: (Name "oiidit-dev-sftp-subnet" / Virtual Network Name "oiidit-dev-vnet" / Resource Group "oiidit-dev"): network.SubnetsClient#CreateOrUpdate: Failure sending request: StatusCode=0 -- Original Error: autorest/azure: Service returned an error. Status=<nil> Code="AnotherOperationInProgress" Message="Another operation on this or dependent resource is in progress. To retrieve status of the operation use uri: https://management.azure.com/subscriptions/f4b73189-92aa-447b-8e41-c1215ecdb061/providers/Microsoft.Network/locations/northeurope/operations/18adf221-97b5-492d-813c-4239ef719d16?api-version=2021-05-01." Details=[]

...

│ Error: creating Subnet: (Name "oiidit-dev-db-subnet" / Virtual Network Name "oiidit-dev-vnet" / Resource Group "oiidit-dev"): network.SubnetsClient#CreateOrUpdate: Failure sending request: StatusCode=0 -- Original Error: autorest/azure: Service returned an error. Status=<nil> Code="AnotherOperationInProgress" Message="Another operation on this or dependent resource is in progress. To retrieve status of the operation use uri: https://management.azure.com/subscriptions/f4b73189-92aa-447b-8e41-c1215ecdb061/providers/Microsoft.Network/locations/northeurope/operations/18adf221-97b5-492d-813c-4239ef719d16?api-version=2021-05-01." Details=[]

After I rerun apply command everything creates just fine. I saw that some people use workaround with parrallelism flag High parallelism errors out with AnotherOperationInProgress · Issue #4285 · hashicorp/terraform-provider-azurerm · GitHub or Subnets on same vnet fail due to parrallel setup · Issue #3780 · hashicorp/terraform-provider-azurerm · GitHub, but I do not want to go this way, because it will make my deployment much slower.

Azurerm provider version: 2.95.0
Az cli version: 2.32.0