Dependency Conflicts

Hello, I am trying to run vagrant plugin install vagrant-aws` however I am getting the error:
errors can commonly be caused by misconfigured plugin installations
or transient network issues. The reported error is:
conflicting dependencies fog-core (~> 1.45) and fog-core (~> 2.1)
Activated fog-core-2.2.3
which does not match conflicting dependency (~> 1.45)
Conflicting dependency chains:
fog-aws (= 3.9.0), 3.9.0 activated, depends on
fog-core (~> 2.1), 2.2.3 activated
vagrant-aws (= 0.7.2), 0.7.2 activated, depends on
fog (~> 1.22), 1.42.1 activated, depends on
fog-core (~> 1.45)
Gems matching fog-core (~> 1.45):
Does anyone know how I can fix these conflicts?

You might try to clean out your plugins using a vagrant plugin expunge. That is kind of the “nuclear option”, that will go ahead and remove all of the plugins you have installed. It’ll get you back to a clean state with respect to Vagrant plugins.