Get Empty Error JSON for some HTTP requests

I am new to Vault, just set it up to run a process that creates keys for a web server, via a company Ansible script. I am using version 1.02.

For a few different functions, I get a weird empty error JSON:

{“errors”:[ ]}
If I change the path or token, I get correct errors. These blank errors also appear in the audit logs for the server.
Here are a couple of functions this happens for:

curl --header “X-Vault-Token: xxxx” --request LIST http://[redacted-ip]:8200/v1/pki/roles
result: {“errors”:[ ]}

Note: I do have a pki role, as evidenced in the gui.

curl --header “X-Vault-Token: xxxx” --request GET http://[redacted-ip]:8200/v1/secret/[anything]
result: {“errors”:[ ]}
in audit log: “response”:{},“error”:""}
(Probably due to not having secrets, but it should tell me! Found this by testing around.)

What am I doing incorrectly here? I’ve enabled the pki and secrets engines at default locations, I actually have a pki role. Any help is much appreciated!

Update - I have upgraded to the latest version (1.3.4) and am still getting the same result.

I solved the issue. Turns out, my script wasn’t failing where it should and I thought it had issued the pki certificate, when it hadn’t. I followed the directions in and this module completed just fine. On to the next failure!