GRPC error when setting up server with server run

I’ve spent the better part of the day trying to figure this out. Hope I’m not missing something obvious.

I’ve successfully installed waypoint on a digital ocean droplet and opened ports 9702 and 9701. I’m running the server with:

waypoint server run -db=data.db listen-http=0.0.0.0:9702 -accept-tos -advertise-addr=[IP]:9701 -listen-grpc=0.0.0.0:9701 -advertise-tls-skip-verify=true

This will successfully give me access to the dashboard on the given IP. I’ve gone through the invite steps and copied the command to set the context on my local machine. But when I try to run waypoint context verify it fails with the message:

Error connecting with context "[IP]-ui": grpc: no transport security set (use grpc.WithInsecure() explicitly or set credentials)

The server address of my local context corresponds to my servers IP and looks like this in the context:
“* | CONTEXT NAME | [IP]:9701”

I thought initially this was because of the self-signed root certificate, but I saw a video on youtube of someone using waypoint successfully with an unprotected site hosted on k8s. Am I missing something?

In case someone is running into the same issue. I solved it with adding the -server-tls-skip-verify flag to the create context command:

waypoint context create \
-server-addr=ADDR:9701 \
-server-auth-token=TOKEN \
-server-require-auth=true -server-tls-skip-verify \
-set-default NAME
2 Likes