Waypoint context verify fails

I’m using Waypoint with Nomad, where I’ve set up the server. I’m trying to connect after setting up my local context:

waypoint context create \
          -server-addr=example.com:9701 \
          -server-auth-token=XXX \
          -server-require-auth=true \
          -set-default \
          -server-platform=nomad \

I have a VPN connection that I’m using, however, it seems that I’m able to reach it, as running the bootstrap remotely works:

$ waypoint server bootstrap -server-addr=example.com:9701 -server-tls-skip-verify

> ! Error bootstrapping the server: server is already bootstrapped

I’m trying to verify my context with waypoint context verify, but it’s timing out:

! Error connecting with context "example-context": error connecting to server: context deadline exceeded

Any ideas to debug would be appreciated!

Try adding -server-tls-skip-verify=true to your waypoint context create command. Hope it will help.

Thanks @DziubaMaksym for responding, you are correct. By default, the flag is false, so you’ll need the =true part. @AngelOnFira Did you maybe lose your initial token and that could be causing your error? If you can’t find the token, then you’ll have to recreate the server - hopefully you don’t lose too much.