HashiCorp KV - Update description

I have enabled KV secret engine under a path secret1. Now I am trying to update the description of it via API. I use following API endpoint but it does not seem to be working.
$body = @{“Description” = “Secret path to contain the passwords and associated secrets.”}

It does not return any error but the change is not reflected.
I think there is something wrong in what I do. Please help.

You’ll either need to specify the description when you enable the mount or after-the-fact using the tune endpoint. In the latter case you’ll need to use as your path.

Looking at the API docs for the KVv2 config endpoint does not show there is a description field you can set so that’s what your current attempt isn’t working for you.

1 Like

Thanks a ton. It worked.