How to upgrade consul-k8s with external consul servers?

So let’s say we are using consul-k8s with external consul servers that run on ec2.

What would be the upgrade path since there’s a compatability issue? If we upgrade servers to a newer version first, consul-k8s might break and if we upgrade consul-k8s first then again it might break because older consul version isn’t supported