Nomad-pack render returns error on every pack I tried

I have added nomad-pack registry and just trying to run out-of-the-box nomad render for hello_world throws the following error. It also throws an error for any other packs I tried as well.

Here is my command:
nomad-pack render hello_world

! Failed To Process Pack

Error:   Pack "hello_world" not found when accessing ".hello_world.job_name"
Details:   The referenced pack was not found in the template context.
Suggestions:   The legacy ".hello_world.job_name" syntax should be updated to use `var "job_name" .`. You can run legacy packs unmodified by using the `--parser-v1` flag
    - Filename: hello_world/templates/_helpers.tpl
    - Position: 4,22
    - Registry Name: default
    - Pack Name: hello_world
    - Pack Ref: latest

I tried both v0.1.0 and nightly as of today with no avail.
Am I missing something?

Hi @andy222,

As the error message suggests, you must pass --parser-v1 CLI argument, as the pack still uses the legacy syntax.

Try the below command and it should work for you.

nomad-pack render --parser-v1 hello_world

I hope this helps!

Thanks a lot. That worked.
I also looked at nomad-pack generate and that generates pack based on new standards and also seems little easier to digest.

Thanks again for your prompt response,