Nomad scale and deploy needs to be graceful


Nomad scale and deployment via API is not graceful. Let us know the best way to get that graceful for single or mass jobs ?


Appreciate if someone could reply to this with some documentation. Thanks.

What have you tried so far? What is the issue? What would you prefer to happen/occur?

Any sample job definition that can be used for reproducing the issue?

Scale down via API"/v1/job/#{job_name}/scale is not graceful. To overcome , have added a way to graceful shutdown on the allocations via kill 15. Looking for some better way to do this.

Is there a parmeter or configuration which does the allocations on a Job graceful during scale down and also for new deployments.

Hi @Vijay-Kaliappan-a102,

Would you be able to clarify what behaviour you are seeing which is not graceful when using this endpoint?

jrasell and the Nomad team

Scaling down is force killing the allocations. Looking for graceful shutdown of allocations during scale down.

When you say “have added a way to graceful shutdown…” I assume you are launching a custom application under Nomad?

If so handling the kill_signal should be the appropriate way.

Could increasing the shutdown_delay and kill_timeout help?

yes tried passing following parameter . Its force kiling when its done via API POST. Its not respecting the SIGNAL .

    agent_h['KillTimeout'] = 30 
    agent_h['KillSignal'] = "SIGINT"