Packer quits with an `SSH timeout` during a reboot when trying to build an Artix-dinit OS

My Setup


OS:                Manjaro XFCE x86_64:  
Apps:      packer (plugins: qemu), virt-install, virt-viewer, virt-manager


OS:                Artix Linux  
Hypervisor:        QEMU KVM  
Architecture:      x64
Machine Type:      qc35
EFI Firmware Code: /usr/share/edk2-ovmf/x64/OVMF_CODE.fd
EFI Firmware Vars: /usr/share/edk2-ovmf/x64/OVMF_VARS.fd

See GitHub - safenetwork-community/SE_bastille-installer-box: Necessary vagrant box files for the box I’m trying to build.

I’m trying to build a vagrant box using Artix Linux OS (dinit) installed and some app that needs to use partitions, so I can’t use docker for this.

The last time I worked on this, I took compromises and support dropped for one piece of software making the box permanently outdated.

That happened to be Manjaro minimal x64, so I’m now looking to use the best alternative and I have my eyes set on Artix, after the Arch forum banned me for trivialities.

So I want to do it right this time around and want nothing but the best of everything that I perceive as such.

One of which is using dinit. It seems like the best alternative to systemd to me, but unfortunately when I run packer build and reboot the virtual machine system during the build, packer starts to hang after /usr/bin/reboot in and I don’t know what cause of this is.

Since the program can be run non-headless, I can see if the reboot does anything to the virtual machine. It does.

The virtual machine boots and I can even check and see that SSH is turned on after reboot, which it is.

Unfortunately, packer is unable to connect.

This log is of my build attempt.

This log is what happens when I replace artix-dinit with archlinux, which uses systemd as it’s standard.

Can anyone here help me with this issue?