Project initialization hangs in web ui

I visit the web interface and create a project. Then I “Manage settings” and add Git settings and waypoint.hcl settings. I click “Apply” and the interface just stays on:

 Initializing project from


It would be nice to have some quick feedback in the web interface about whether or not the settings are working. I even checked the server logs and did not see any helpful information about why the project settings are not being accepted.

Sorry to hear you’re running into this issue.

To help figure this out, could you let us know:

  1. Where are you running Waypoint server? (i.e. Kubernetes)
  2. Where are you running the Waypoint remote runner? (same as above? somewhere different?)

Did you see anything in the runner logs that looked like it might be related?

Many thanks!

@jamie, I am running the Waypoint server on Nomad. I did not specify a runner. I assume that the web ui takes care of setting one up for me. Are there runner logs that are separate from the Waypoint server logs?

The web UI doesn’t automatically set up a remote runner for you, but the waypoint install step may have taken care of it. Could you check in Nomad to see if you can find mention of a waypoint runner?

Are you saying that when I fill out this “Git settings” form in the web ui, it does not start a runner?

I do not use waypoint install. I have Waypoint setup as a job/pack in Nomad. I install Waypoint using:

nomad-pack run waypoint --var-file=waypoint.hcl --registry=my-company-packs --ref=latest

Where in Nomad would I look to see mention of a Waypoint runner? I looked in the task logs for the Waypoint job and did not see any reference to “runner”.

That’s correct. The server itself does not spawn runners. Instead, Waypoint requires that you install at least one single “static” runner in your target environment. The static runner is then responsible for spawning “on-demand” runners, which in turn perform remote operations such as remote init, remote build etc. The following docs pages cover this area:

If you schedule a Waypoint runner job in Nomad, that runner should pick up the remote init operation (and all other remote operations) and start executing them. See the “additional runners” docs for more detail on this.

1 Like

Oh! Ok, that is making more sense. I setup the Nomad job/pack with a task that does waypoint server run ..., but that is the only task. It sounds like I should create an additional sidecar task that does a waypoint runner agent ... as well.

Thanks for the tip! Trying that out now.

Glad I could help!

This conversation made us realize we could make all this much more obvious in the web UI. I’ve filed an issue here to track making that improvement:

Thanks for helping us improve Waypoint!

1 Like

Awesome! I am glad to be a part of making Waypoint better. I am looking forward to getting it configured and into a state that can be approved for use in my production environments at work. :star_struck:

1 Like