Waypoint Remote Runners configuration question

Hey everyone, I was wondering if someone could help me with setting up a remote Waypoint runner. My goal is to have 2 - 3 remote Waypoint runners that can accept workloads. If I am understanding correctly, Waypoint remote runners can do the work of building, deploying, and releasing, rather than sending all that work to the CLI. What I am having a hard time figuring out is how to send the work to the remote runner? I have gone through the documentation but I’m not having a lot of luck in figuring this piece out.

Here is what I have done so far.

  1. Deployed a Waypoint server (EC2) and connected to it through a Network Load Balancer.
  2. Deployed a WayPoint Runner (EC2)
  3. Configured the Waypoint Runner
 WAYPOINT_SERVER_ADDR=myDomain.com:9701 \
  WAYPOINT_SERVER_TLS=true \
  WAYPOINT_SERVER_TOKEN=mySuperSecretTokenHere \
  WAYPOINT_SERVER_TLS_SKIP_VERIFY=true \
  waypoint runner agent
  1. Configured my waypoint.hcl to use a remote runner.
project = "nginx-project"

runner {
  enabled = true

  data_source "git" {
    url  = "https://github.com/hashicorp/waypoint-examples.git"
    path = "docker/static"
  }
}

# Labels can be specified for organizational purposes.
# labels = { "foo" = "bar" }

app "web" {
  build {
    use "docker" {
    }
  }

  deploy {
    use "docker" {
    }
  }
}

When I issue the command waypoint up, Waypoint deploys the application to my local workstation. Any pointers/suggestions as to what I might be doing wrong. If there is a spot in the docs that I missed, please feel free to point me there.

Hi @karl-cardenas-coding :wave:

Are you depolying Waypoin in Nomad?

If not, the Waypoint forum would be a better place to ask this.

@lgfa29 I have no idea how I ended up on the Nomad channel :man_facepalming:
Anyway, I solved my problem, but thank you for trying to help :slight_smile: