S3 Bucket (tcb-app-qa-hp): failed to refresh cached credentials

Attempting to create a S3 bucket using Terraform. Here is what main.tf looks like -

terraform {
required_providers {
aws = {
source = “hashicorp/aws”
version = “~> 4.16”

required_version = “>= 1.2.0”

provider “aws” {
region = “us-east-1”

resource “aws_s3_bucket” “s3_bucket” {
bucket = “tcb-app-qa-jr”

After ‘terraform init’ and running ‘terraform plan’, this is the error I see:-

aws_s3_bucket.s3_bucket: Creating…

│ Error: listing tags for S3 Bucket (tcb-app-qa-hp): failed to refresh cached credentials, failed to load credentials, deserialization failed, failed to decode error message, EOF

│ with aws_s3_bucket.s3_bucket,
│ on main.tf line 16, in resource “aws_s3_bucket” “s3_bucket”:
│ 16: resource “aws_s3_bucket” “s3_bucket” {

~ bucket_regional_domain_name = “tcb-app-qa-hp.s3.amazonaws.com” → (known after apply)

I tried to rm main.tf and do this over with a new bucket name with no luck. I also tried to rm terraform.state file and try this over and it didn’t work.

What does the error mean and how can I get past it?