Terraform plan detecting changes for everytime plan is run

I have started running into an issue since upgrading to azurerm provider 2.0 where terraform is detecting changes even though there are no changes in my code particularly tags for a resource. Tags are inherited from resource group(which is created separately) to all the resources created in that resource group so we do not pass tags in our terraform code to create resources.
First terraform plan and terraform apply works just fine but when I run plan again, terraform is verifying the end state of the resource and my code and trying to change tags to null.

~ tags                         = {
          - "app-id"           = "1234" -> null
          - "application"      = "testapp" -> null
          - "sdlc-environment" = "test" -> null


So, this happens everytime I run plan and apply. And also started noticing this from azurerm provider 2.0 and also in 2.1. btw, I am using terraform 0.12.23

Did anyone else face this issue and are successful resolving it?