Unable to deploy using Waypoint Netlify plugin

When I try to execute waypoint up without token I always get an error like below one. I never get authorization screen or url. Even after .waypoint folder removal,

[GET /sites][401] listSites default &{Code:0 Message:}

When there is explicitly defined site_id and access_token, the same error shown

[GET /sites/{site_id}][401] getSite default &{Code:0 Message:}

When I manually execute https://api.netlify.com/api/v1/sites/ with provided token I get successful response from netlify API. What I’m doing wrong?

Here is my configuration

project = "example"

    app "landing" {
    path = "./landing"
    build {
        use "files" {}
    deploy {
        use "netlify" {
            access_token = "personal access token from netlify"
            site_id = "app id from netlify website settings"

I have a similar issue. I’ll ask the developer that worked on the Netlify plugin.

Hi there, thanks for reporting this. There are a variety of issues with the Netlify plugin at the moment – this discusses them: https://github.com/hashicorp/waypoint/pull/739

Some of those may actually be upstream in the core of Waypoint, but the commit on that PR should resolve the issue you’re seeing. However, having your access token in the waypoint.hcl perhaps should not be encouraged/possible. But you’re welcome to try building that branch if you want. See instructions to compile Waypoint here. The server won’t need to be updated for that.

@yhortuk I did try to use a Waypoint build with that fix and there still seems to be some other issues. So you may want to wait until there is another update.