Vagrant box add on macOS 11.1 (Big Sur) error


Further to my earlier post Kitchen-ci and VMware Fusion 12 + Vagrant plug-in I tried to create a vagrant box as follows:

cd ~/Virtual Machines.localized/w2012.vmwarevm
touch metadata.json
cd ..
tar cvzf w2012.vmwarevm/*
vagrant box add --insecure --provider vmware_desktop --name w2102_dec2020

Output as follows:
==> box: Box file was not detected as metadata. Adding it directly…
==> box: Adding box ‘w2102_dec2020’ (v0) for provider: vmware_desktop
box: Unpacking necessary files from: file:///Users/…/Virtual%20Machines.localized/
The box failed to unpackage properly. Please verify that the box
file you’re trying to add is not corrupted and that enough disk space
is available and then try again.
The output from attempting to unpackage (if any):
x W2012-3.2.12-14DEC20.vmwarevm/Applications/
bsdtar: Pathname can’t be converted from UTF-8 to current locale.
etc. There is a lot of these lines

This worked with macOS Catalina.

Any suggestions please?

Solved this issue by adding
export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8
to .bash_profile

From macos - In OS X Lion, LANG is not set to UTF-8, how to fix it? - Stack Overflow