Vagrant + Virtual box, create VM without network connection

Hello Community,
I’m here requesting some kind help from your side. Really I spent many days trying to figure out, reading forums, and testing all workarounds I found but I couldn’t find any solution to solve my issue so far.
Let me explain, I’m working on my work laptop, create windows VM, with vagrant, with mwrock/windows2016,
When I run a vagrant up I always have the error of the timeout, but the VM is created successfully, what I wonder is that is created without internet connection. I assume that could be a problem why the winrm could not connect the vm and end by time out.
I run exatcly the same in other personal laptop and It’s working perfectly OK.
I realize that is some configuration on my work laptop that is making some interference, I tried many things, and compare both laptops and I find similar configurations, but I fond some difference in the laptop that is working ok, the VM , wich internet works, have a Teredo Tunneling Pseudo - Interface, running and in my work laptop, where the vm do not have internet connections, that doesn’t exist.
Could be the issue between the 2 enviroments? Any idea how can I fix it?
(I also tried disabling the firewall)
Any suggestion is welcome

This is my config on both laptops
Virtual Box 6.1
Vagrant 2.2.9
Windows 10

Thanks in Advance

Error_
→ ~\Documents\my-first-vagrant-vm [master +56 ~0 -0 !]› vagrant up
Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Importing base box ‘mwrock/Windows2016’…
==> default: Matching MAC address for NAT networking…
==> default: Checking if box ‘mwrock/Windows2016’ version ‘0.3.0’ is up to date…
==> default: Setting the name of the VM: my-first-vagrant-vm_default_1593366285024_71725
==> default: Fixed port collision for 3389 => 3389. Now on port 2200.
==> default: Clearing any previously set network interfaces…
==> default: Preparing network interfaces based on configuration…
default: Adapter 1: nat
default: Adapter 2: hostonly
==> default: Forwarding ports…
default: 3389 (guest) => 2200 (host) (adapter 1)
default: 5985 (guest) => 55985 (host) (adapter 1)
default: 5986 (guest) => 55986 (host) (adapter 1)
default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running ‘pre-boot’ VM customizations…
==> default: Booting VM…
==> default: Waiting for machine to boot. This may take a few minutes…
default: WinRM address: 127.0.0.1:55985
default: WinRM username: vagrant
default: WinRM execution_time_limit: PT2H
default: WinRM transport: negotiate
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured (“config.vm.boot_timeout” value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase