Vsphere-iso build - no boot command text being typed

I’m using the this particular build to create a Rocky Linux 8 template but when running the build, none of the boot commands are typed out. I do see that the directional keys are being pressed as well as the enter key. I’d tried adding a boot_keygroup_interval as well as increasing the <wait> entries to <wait5>, <wait10>, etc. but nothing works. The outcome is always exactly the same. The weird thing is that I have another cluster where the same config works. Both are running the same version of vCenter (7.0.3 Build 20395099). Both are being run from Linux boxes on the same VLAN as the vCenter so no firewall in between to cause issues. Packer version is also the same across the board (1.8.5). No errors reporting in vCenter nor packer’s output to the console.

Hi, this is my boot command for a RockyLinux 9 with EFI (It can be different with bios)

    boot_command = [
        " text inst.ks=http://{{ .HTTPIP }}:{{ .HTTPPort }}/ks.cfg",

I’m the maintainer of the referenced project.

Check to ensure you have granted the Virtual Machine > Interaction > Inject USB HID scan codes (VirtualMachine.Interact.PutUsbScanCodes) privilege to the account context.

The project’s README.md has a full list of the required privilege as well as a Terraform example.

@Joffrey mine is slightly different since I’m not using the web server to serve the kickstarter file. Everything else is identical.

I actually used the included terraform plan to create the role. I just double checked the permission. The one that is set is Inject USB HID scan codes which I guess is the exact same one.

EDIT: Also wanted to say that I tried this using the credentials of the administrator@vsphere.local account and the same thing happened. So I don’t believe this to be a permissions issue.

@tenthirtyam so I’ve discovered the issue. Turns out the boot command in this particular case is only good if you are booting using UEFI which I had changed to BIOS. I modified it slightly to used the required keystrokes and it works now.