Error when trying to connect to my first target in the tutorial

I started the boundary tutorial and in the “Connect to Your First Target” section, tried the
boundary authenticate password -auth-method-id=ampw_1234567890 -login-name=admin -password=password
command. in result I got the error:

Error reading auth token from system credential store: exec: "dbus-launch": executable file not found in $PATH

then I tried to install dbus-x11 in the container and the error changed to
Error reading auth token from system credential store: The name org.freedesktop.secrets was not provided by any .service files

Is it possible that the problem is with the Boundary itself? If not, then what should I do about it?


I was going to post my error but I have found some conversations about this on github
Starts here:
and continues to here:

I am on Oracle Linux 7 and running the gnome-keyring-daemon steps cleared up my org.freedesktop.secrets errors. This was added to the documentation but not the learn docs:

However I am still getting errors. My token expires as soon as its created and i couldn’t not read a boundary target. I added this to issue #697


Thank you for your response. That was helpful. I guess I’m just gonna use -token_name=none, since it doesn’t matter much to me.

The missing instruction was added to the Learn tutorial as well. Thank you so much for reporting this. :pray:

Awesome. Thanks for updating the Learn Tutorial. Also according to the Github issue, a PR has been sent into to change the default behavior on Linux

1 Like