Missing Button Connect in boundary ui

Trying Boundary, but even if i can connect with boundary cmd line to my target, i dont see the “connect” button on ui.
Why? I need it for no-tech ppl.

Here screen example :

Tested with self managed, but also on boundary cloud.

Hi @Gwojda the screenshot above is from the Boundary Admin UI. Your end users need the Boundary Desktop client in order to see the “Connect” button to create sessions.

Thanks, got the button with client desktop.
Unfortunatly, i still can’t connect with boundary to my services.

Connexion works well, state is pending, but :

ssh -p 33495
kex_exchange_identification: read: Connection reset by peer
Connection reset by port 33495

0 error on logs, worker say no session is running:

But session is here :


Also tested with 0.11.2 version, same error.
Also tested with on external worker, same problem :worker is register but he got no traffic.
Still, no error in log, only “observable” type. Should have “system” logs type but nothing.

Are the auth attempts showing in the remote hosts auth log (/var/log/auth.log, /var/log/secure, etc)?

And can you share the verbose ssh output (-vvv)?

You didn’t mention what target you’re using. It seems you’re running Boundary in Dev mode.

If you haven’t changed the default target address for the Generated target, that means it’s trying to connect to In that case, make sure you have SSH running on that host and listening on the loopback interface.

If you have changed the target address, make sure that the server where your Boundary worker is running has access to the target: network connectivity and packets are not being dropped by security appliances in between. You can test that by running:
nc -v -z <target ip> 22 from that server. (need to have netcat installed - optionally, use the ssh client itself).

Lastly, if everything worked so far, as @conor-mccullough mentioned above, please share connection logs from the target and verbose output of the ssh client.

1 Like