[Solved] Login to web interface not working with admin but works with CLI

For some reason, trying to use admin and the generated password on the web interface I just throws

" Error
Authentication Failed "

I can authenticate just fine using the cli with the same credentials. This worked fine using the dev instance but not using a “production” instance. Anyone else has this problem?

I cleaned out the postgres instance and did another db init, but same problem with the new credentials.

I did copy paste the exact password from cli with no extra characters or spaces added.


changed cors to false (As opposed to the official example) in the controller example.
cors_enabled = false

1 Like

Ah interesting. The example has cors because a lot lot of people want it but we should maybe revisit the example to ensure it will work for people. Which page were you looking at?

This one: https://www.boundaryproject.io/docs/configuration/controller

I remember cors was troublesome when trying to get consul up and working as well :slight_smile:

I’ve updated the example to have those values commented out by default and instruct the user to set origins appropriately if uncommenting. Sorry about the trouble!

1 Like