Unable to login to Admin UI in non Dev mode

Hi all,

Currently when running boundary with the following command

boundary server -config boundary-controller.hcl and the postgres is
boundary database init -config boundary-controller.hcl

I seem to have great difficulty in being able to login into the admin UI. I user the boundary provider for terraform to create scopes, users and auth-methods but still unable to login. The error I get on the web UI is

Authentication failed.

Any ideas would be welcome.

Does logging in as the built-in admin user created by boundary database init work, or does that fail too? What happens if you try to log in using the Boundary CLI as a user that fails on the admin UI?


I am able to login to the cli and the boundary terraform provider with the created user, but not on the UI .

The builtin admin user created does work on the cli and terraform provider, but again not in the CLI


Any feedback on this :slight_smile:

I’ve never seen it where the CLI works and the admin UI doesn’t. What version is everything (CLI/controller/workers)? Are you using a released version of Boundary or one you built from main?


Thanks for your reply.

Boundary version 0.3.0
Boundary Provider Terraform version 0.1.2

Hi there. This could be a CORS configuration issue. Can you check that cors_allowed_origins has a value?
You can also temporarily disable CORS in your config by disabling cors_enabled to verify if this is a CORS setup problem.


the following is set

Uncomment to enable CORS for the Admin UI. Be sure to set the allowed origin(s)
to appropriate values.

cors_enabled = true
cors_allowed_origins = [“https://yourcorp.yourdomain.com”, “serve://boundary”]

This might sound obvious. I’m just double checking that https://yourcorp.yourdomain.com value is replaced with the the origin used to access the admin UI from the browser.

Can also allow all origins by settings cors_allowed_origins= ["*"] if setting explicit origins isn’t a preference.

Awesome :clap: gsusmi

I am now able to login with a controller config. I did not think that would be the issue.

Thanks again

Brilliant! Thank you for trying out Boundary.