Boundary cli issue while trying to connect using boundary desktop

Is there any configuration to be done before to run boundary cli. Because when trying to open cli , the cli not opening ,i guess there’s some runtime issue. And what are the credentials to be passed in ssh,is it the credential store integration

Thanks for your interest in Boundary @akhila98. Just to confirm, have you downloaded a Boundary binary and placed it in your PATH variable? You can do this at our downloads page and can use the package managers listed for your operating system.

If you have installed the Boundary binary on your client device, are you receiving an error when you try to use the CLI that you could share with us?

Thanks!

So what i am trying to do is, i have installed boundary also boundary desktop in my ec2 instance , so i was trying to connect my target using boundary desktop , after which we have to copy the proxy url to ssh session, so this ssh session i was trying to do with boundary cli, but my cli is not opening, its getting closed when trying to open. So is there any other way activating the session other than the cli where we can copy the proxy url and establish active session.

If you log in and start a session with the Boundary desktop, you don’t need to use the CLI to connect to it – you would use your regular SSH client to do that. If the Boundary session proxy is 127.0.0.1:18932, you would give the SSH client 127.0.0.1 as the SSH host and 18932 as the SSH destination port, then it would connect through the Boundary proxy.

The CLI isn’t something you open and work in persistently – every time you run it, it does one operation and then closes again. So you would never just run boundary all by itself, it would always be boundary [some subcommand] [whatever arguments the CLI or that subcommand needs] and you would get either a successful result, or an error about what what you tried failed.

So I tried the above solution to connect to boundary desktop using putty and facing the following issue.
[ec2-user@ip-XXX-XX-X-XXX boundary_0.8.1]$ ssh -p 51938 127.0.0.1
ssh: connect to host 127.0.0.1 port 51938: Connection refused

@omkensey also when trying to do ssh username@host ip ,it is getting connected.

It sounds like you have two desktop systems here, your own local one and one in EC2. If you start a Boundary target session on one, make sure you connect to the target on that same one.

No,I will explain what exactly i am trying to do is ,Firstly i have downloaded boundary in one ec2 instance and using remote desktop we have boundary console and there we have boundary desktop, so when trying to connect desktop in rdp ssh client we are facing this issue.

So you have the Boundary desktop running on the same host as Boundary itself? I’m still not clear on the connections between the EC2 instance running Boundary and other things.

@omkensey yes it is running on same host. And then when trying to connect using ssh i am facing the connection refused issue. I am using putty to start ssh session.
So could you help me out with this, as i am not finding a solution regarding this

I’m not sure where PuTTY is happening here. In a previous message you had this:

$ ssh -p 51938 127.0.0.1
ssh: connect to host 127.0.0.1 port 51938: Connection refused

which looks to me like OpenSSH on Linux, not PuTTY on Windows. Where is PuTTY running?

Ya, its in linux itself, putty is running on the host where boundary is, on same ec2 instancr

@omkensey Also i had forgot to mention i had updated by boundary binary, which currently has version 0.8.1 and my boundary client version is 1.4.0 , is the connection refused issue cause of that?
When i try to download the windows version of boundary desktop 1.4.3 I am facing the forbidden issue, the link i using is from the release page of boundary itself.

Definitely the Boundary CLI version should match the server 0.x version and the Desktop version should be the one released alongside the server version. If your server is 0.7.y your CLI should also be 0.7.y; likewise for 0.8 and the (just-released!) 0.9.

If I’m spelunking the repo correctly, the matchup between the various Desktop versions and server versions is as follows:

  • Desktop 1.3.0 = server 0.6.y (0.6.0)
  • Desktop 1.4.0 = server 0.7.y (0.7.1)
  • Desktop 1.4.1 = server 0.7.y (0.7.3)
  • Desktop 1.4.2 = server 0.7.y (0.7.6)
  • Desktop 1.4.3 = server 0.8.y (0.8.0)
  • Desktop 1.4.4 = server 0.9.y (0.9.0)

When i try to download the windows version of boundary desktop 1.4.3 I am facing the forbidden issue, the link i using is from the release page of boundary itself.

What happens if you go straight to the Desktop 1.4.3 download URL on our Releases site? If you’re getting an error there too can you show a screenshot of it?

Facing this forbidden issue

That looks like an administrative policy set by your IT team, perhaps. Could you check with them to see if they allow downloads from our releases?

@omkensey Hey i am receiving
ssh : connect to host ssh connection timed out when trying to connect through boundary desktop.

Connection timeout usually means a firewall is dropping traffic somewhere. Are you trying to connect to a remote host or your local desktop through Boundary?

@omkensey trying to connect to remote host