Error: no suitable auth method information found

I get the following message when I run terraform apply "│ Error: no suitable auth method information found

│ with module.boundary.provider[“Terraform Registry”],
│ on boundary\ line 13, in provider “boundary”:
│ 13: provider “boundary” {
I am following the AWS Example Deployment in AWS instructions.

Did you do the terraform apply -target module first before doing the main terraform apply?

Hi Omkensey! No I didn’t but it worked after I commented out the line. Then I had to comment out the boundary line in as it kept complaining about “boundary” security group already exist. All seems to be provisioned (two controllers, two workers, database and a target). However when I connect :9200, the only scope listed is “Global”, and when I select the “Global” scope I am not presented with the items related to the scope. So no login page comes up just the option to Select Global scope and after selecting nothing happens.


It sounds like some resources got created but not others, so the first apply errored out when it tried to initialize the boundary provider but the environment wasn’t ready for that yet. You probably should reset the environment and restart from the -targeted apply, otherwise you’ll be in a state that’s hard to debug and likely won’t work.

Makes sense! Will deploy to another region and report any issues I run into. Thanks for your help!